From 13:00 to 16:30, it was not possible to generate return labels via the returns dashboard. This issue did not affect the returns portal. The problem has been fully resolved, and label generation from the dashboard is working normally again. No data was lost or exposed. We appreciate your patience while we worked to restore service. If you have any questions about this incident, please reach out to support@8returns.com.
Posted Aug 26, 2025 - 19:37 CEST
Investigating
We are currently investigating an issue where some customers are not receiving a return shipping label when registering a return through the returns portal. In addition, it is currently not possible to create return labels via the returns dashboard. Once the issue is resolved, we will re-issue the failed labels and resend return confirmation emails to all affected customers. Thank you for your patience!
Posted Aug 26, 2025 - 17:16 CEST
This incident affected: Returns Portal and Returns Dashboard.