Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 27, 2025 - 23:30 CEST
Scheduled
During this period, users will not be able to generate return labels for most carriers. Only DHL and Swiss Post label generation will remain fully operational.
We apologize for any inconvenience this may cause and recommend planning your returns processing accordingly. Our team will work to complete the maintenance as quickly as possible and restore full carrier support.
We appreciate your understanding and patience.
Posted Aug 05, 2025 - 15:14 CEST
This scheduled maintenance affected: Returns Portal, Returns Dashboard, and Carrier API.