Partial Outage

Incident Report for 8returns

Resolved

This incident has been resolved.
Posted Aug 13, 2025 - 15:15 CEST

Investigating

From 14:30 to 15:10 CEST, our application was unresponsive across all major touchpoints—dashboard, returns portal, and API. Users might have experienced delayed interactions during this window.

The application returned to full functionality by 15:10 CEST, by gradually handling all pending web requests.
No data was lost or exposed. The incident has been fully resolved; services are operating normally.

We're committed to keeping our users informed and appreciate your patience while we maintained service reliability. If you have any questions about this event, please reach out to support@8returns.com
Posted Aug 13, 2025 - 14:30 CEST
This incident affected: Returns Portal, Returns Dashboard, and API.