A fix has been implemented and we are monitoring the results.
Posted Mar 10, 2025 - 12:15 CET
Investigating
We experienced an unexpected disruption in the Returns Portal, which was inaccessible from 10:48 to 11:58. We will provide further updates as more information becomes available. We apologize for any inconvenience caused.
Posted Mar 10, 2025 - 12:00 CET
This incident affected: Returns Portal, Returns Dashboard, and API.